Talk:Getting your fink installation to use packages that I have pre-compiled

From OS X Scientific Computing

Jump to: navigation, search

i gather that one should have Tiger (or the l.g. mac os x) or else there is uncertainty as to how things will proceed. can anyone confirm? (i have mac os x 10.3.9).

Yes. You need 10.4.x I don't have a 10.3.x machine anymore, so I have no way to keep those packages up to date. The upgrade is well worth it.

here is a fink question : "how do i" make fink install the new darwin if i already updated and fink only lists the old one? here's what i did: i `fink update-all` fine, i get some incompatibilities with my old darwin, i see darwin with `fink apropos darwin` with "i" status, but..

-bryan

I don't think you can. If you type fink list darwin you will see

 i   darwin                   8.5.0-1            [virtual package representing the kernel]
 

which means it is not a real package. (That number corresponds to 10.4.x.) Darwin is open-source, and I guess you could try to upgrade it, but I think that would just open a huge can of worms. Just mooch the install disk from someone...

ok, i'm 10.4.3 so... now should i remove folders like this:

/sw/fink/10.2/

/sw/fink/10.2-gcc3.3/

(...)

leaving only

/sw/fink/10.4

...and if i am 10.4.3 + Xcode, does that mean i STILL have to deal with the "use this X11 not the other X11 and also use X11SDK" issues as described in detail elsewhere? i AM sorting through the pkgdiff results now...

-bryan

Personal tools